How to shape an extruded surface ?

DELFTship forum Hull modeling How to shape an extruded surface ?

Viewing 6 reply threads
  • Author
    Posts
    • #33538
      AvatarYann
      Participant

      Hello everybody,
      I am working on a barge hull and it’s my first design. I am quite happy so far with the result (thanks to amazing Delftship !) but I am now encountering a problem using the Extrude Edges command. I would like to add some sort of “balcony “ at the top of the bow.

      The thing is that if am able to generate a new face on the Z axis which is a copy of the selected edge, I am then unable to shape properly this new face on the X axis (sort of “s” design). I tried to add news points but they are not located ON the new face surface…. As a result, I lost control in the Y axis and the balcony looks terrible 🙁

      What would be the easiest way to accomplish this?

      As a beginner, I probably miss some important features / behaviours of Delftship, sorry for that…

      Any help would be very appreciated

      Yann

    • #33540
      AvatarMarven
      Keymaster

      The process is simple,

      First insert edge from the top to the bottom, and also one at the aft part of the surface, just to keep your grid as regular as possible.

      Then make the upper point a corner point so the surface makes a sharp turn.

      See the image below for clarification.

      Attachments:
    • #33543
      AvatarYann
      Participant

      Thank you, Marven, for you help and explanations.

      It’s now almost OK but I keep having trouble with one thing. As you can see in the side view, my points are not located at the right places. When creating new points with the command Edit / Edge / Split, news points are automatically created at the middle of the previously selected edges…
      If I try to move these points on the X axis, all the hull shape is changing in that area 🙁

      Is there any possibility to insert the new points directly at the right places where they should be? (Regarding the profile view)

      Thanks a lot

      Yann [file name=Hull.jpg size=113637]http://www.delftship.net/delftship/media/kunena/attachments/legacy/files/Hull.jpg[/file]

      Attachments:
    • #33544
      AvatarMarven
      Keymaster

      No, the points are by default inserted in the middle.
      But it should be very easy to move them to the correct place without altering your hull shape.

    • #33550
      AvatarYann
      Participant

      It should be very easy to move them to the correct place without altering your hull shape.

      Well, I wish it was 😉
      I spent a couple of hours trying to reshape my hull bow after having introducing these new points. But now I understand where my trouble is, even if I still don’t know how to solve it…

      Initially, my hull as few “curve control points” as the below one on the attached picture. By having exactly the same coordinates in the X axis, I could create several control curves, one of the top of the other, with exactly the same curvature. Fine, but know, on the same edge, I am introducing a compulsory “corner point” instead of curvature control. As a result, I cannot easily find the exact position of the curve below. At this point I would dream about some corner points which could have the “corner” property only for some axis (only Z and X in my case) and the Y still acting as a curvature control.

      I don’t know if my explanations are clear enough but I would be very happy to get any advice on that “particular” situation.

      Thanks
      Yann

    • #33579
      AvatarTiago
      Participant

      Then make the upper point a corner point so the surface makes a sharp turn.

      Hi Marven.

      How do I make a point a corner point?
      I see no option for that…

      I’m using the Free version 3.20. Is that available only in the Pro version?

      Thanks,

      Tiago

    • #33581
      AvatarTiago
      Participant

      Oops… got it. the small window with the corner coordinates has the ‘corner’ checkbox.

      That window, however, does not always show, but that’s a different matter.

      Sorry for ‘hijacking’ the topic.

Viewing 6 reply threads
  • You must be logged in to reply to this topic.