Part of layer is not shown as ‘below sea-level’

DELFTship forum Hull modeling Part of layer is not shown as ‘below sea-level’

Viewing 3 reply threads
  • Author
    Posts
    • #38705
      GLS
      Participant

      Sorry, but I am pretty new with the Delftship software.

      However, I did setup a ship quite well.
      But adding an extra plate, below sea-level, does show it, as it was above sea-level (no color change).

      How-can this happen, but more important; how can I fix it?

      Thanks.

    • #38706
      Maarten
      Keymaster

      Hi SNGSC6,
      Welcome to our forum!

      Your issue is quite common, and not really an error (It won’t interfere with calculations). When adding new surfaces, it can be difficult to calculate the ‘outside’ – so we make a ‘best guess’. Obviously this is not always correct- but as long as layers are hydrostatic the proper normals can be calculated using the ‘Check model’ function on the Tools tab. This function will also alert you to any leak points that may be present.

      I hope that fixes you issue!

    • #38707
      GLS
      Participant

      Thanks Maarten,

      Although, it does seems strange to me. This due to the fact that every point can be allocated below or above sea-level, by comparing the ‘z-value’ with the ‘Draft-value’.

      However, the ‘check-model’ option, does give more than 2000 leak points, which is probably caused by using different layers for the different plates (‘multi-knik’ model). Although the different points have been given the same values for the same point ion the different layers.
      So I do not know if that procedure has finished properly and if the ‘above or below sea-level calculations’ has completed or even probable; it did not start at all.

      For the time being, I moved the plate to a separate layer, and I did change the color manually.

    • #38708
      Maarten
      Keymaster

      Hi SNGSC6,

      I understand this may seem strange- there are two things that you need to keep in mind: Separate surfaces (in separate or same layers) will ALWAYS be ‘leaky’ on their edges.

      Putting points om the same coordinates will NOT make then ‘the same point’- and it is strongly discouraged to place points on exactly the same coordinates- this can cause worlds of hurt later in the workflow…

      A non-leaking (hydrostatic) surface will always have an inside (dry) and an outside (wet if below waterline) side- this is determined by the normals.

      To close the leaks you have introduced I recommend adding surfaces between the edges of the separate layers. You can keep the layers separate. For a crease edge select the relevant edge and select ‘crease’ from the edge menu…

      Good luck!

Viewing 3 reply threads
  • You must be logged in to reply to this topic.